use strict;
my $str = 'http://www.mysite.com/lmds?vanall=true
https://mysite.com
https://mysite.com/pricing
https://www.mysite.com/lmds
https://mysite.com/lmds
http://www.mysite.nl/lmds
http://mysite.nl/lmds
http://test.mysite.com/lmds
http://mysite.nl/lmds
http://www.mysite.nl';
my $regex = qr`https?://(?:www.)?mysite\.(?:nl|com)(.*)`mp;
my $subst = 'https://www.commoneasy.nl${1}';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";