package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?://(?:www.)?mysite\.(?:nl|com)(.*)`)
var str = `http://www.mysite.com/lmds?vanall=true
https://mysite.com
https://mysite.com/pricing
https://www.mysite.com/lmds
https://mysite.com/lmds
http://www.mysite.nl/lmds
http://mysite.nl/lmds
http://test.mysite.com/lmds
http://mysite.nl/lmds
http://www.mysite.nl`
var substitution = "https://www.commoneasy.nl${1}"
fmt.Println(re.ReplaceAllString(str, substitution))
}