import Foundation
let pattern = #"https?://(?:www.)?mysite\.(?:nl|com)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.mysite.com/lmds?vanall=true
https://mysite.com
https://mysite.com/pricing
https://www.mysite.com/lmds
https://mysite.com/lmds
http://www.mysite.nl/lmds
http://mysite.nl/lmds
http://test.mysite.com/lmds
http://mysite.nl/lmds
http://www.mysite.nl
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"https://www.commoneasy.nl${1}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)