import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z]{2,3})(([\\-\\_][a-zA-Z]{4})+)?([\\-\\_][a-zA-Z]{2})?([\\-\\_][a-zA-Z]*)?(@(collation|calendar|currency|numbers)\\=[a-zA-Z]*[;]?((collation|calendar|currency|numbers)\\=[a-zA-Z\\-\\_]*[;]?)*)?";
final String string = "fr\n"
+ "fr-fr\n"
+ "fr_FR\n"
+ "zh_Hans_CN\n"
+ "zh-hans-cn\n"
+ "fr@collation=phonebook;calendar=islamic-civil\n"
+ "sr_Latn_RS_REVISED@currency=USD\n"
+ "en_IE@currency=IEP\n"
+ "en_IE_PREEURO\n"
+ "sr_Hans_Latn_RS_REVISED@currency=USD\n"
+ "fre_FR\n"
+ "und\n"
+ "fr@collation=phonebook;calendar=islamic-civil;currency=IEP";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}