const regex = /^([a-zA-Z]{2,3})(([\-\_][a-zA-Z]{4})+)?([\-\_][a-zA-Z]{2})?([\-\_][a-zA-Z]*)?(@(collation|calendar|currency|numbers)\=[a-zA-Z]*[;]?((collation|calendar|currency|numbers)\=[a-zA-Z\-\_]*[;]?)*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z]{2,3})(([\\-\\_][a-zA-Z]{4})+)?([\\-\\_][a-zA-Z]{2})?([\\-\\_][a-zA-Z]*)?(@(collation|calendar|currency|numbers)\\=[a-zA-Z]*[;]?((collation|calendar|currency|numbers)\\=[a-zA-Z\\-\\_]*[;]?)*)?', 'gm')
const str = `fr
fr-fr
fr_FR
zh_Hans_CN
zh-hans-cn
fr@collation=phonebook;calendar=islamic-civil
sr_Latn_RS_REVISED@currency=USD
en_IE@currency=IEP
en_IE_PREEURO
sr_Hans_Latn_RS_REVISED@currency=USD
fre_FR
und
fr@collation=phonebook;calendar=islamic-civil;currency=IEP`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}