// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-zA-Z]{2,3})(([\-\_][a-zA-Z]{4})+)?([\-\_][a-zA-Z]{2})?([\-\_][a-zA-Z]*)?(@(collation|calendar|currency|numbers)\=[a-zA-Z]*[;]?((collation|calendar|currency|numbers)\=[a-zA-Z\-\_]*[;]?)*)?").unwrap();
let string = "fr
fr-fr
fr_FR
zh_Hans_CN
zh-hans-cn
fr@collation=phonebook;calendar=islamic-civil
sr_Latn_RS_REVISED@currency=USD
en_IE@currency=IEP
en_IE_PREEURO
sr_Hans_Latn_RS_REVISED@currency=USD
fre_FR
und
fr@collation=phonebook;calendar=islamic-civil;currency=IEP";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}