import re
regex = re.compile(r"^([a-zA-Z]{2,3})(([\-\_][a-zA-Z]{4})+)?([\-\_][a-zA-Z]{2})?([\-\_][a-zA-Z]*)?(@(collation|calendar|currency|numbers)\=[a-zA-Z]*[;]?((collation|calendar|currency|numbers)\=[a-zA-Z\-\_]*[;]?)*)?", flags=re.MULTILINE)
test_str = ("fr\n"
"fr-fr\n"
"fr_FR\n"
"zh_Hans_CN\n"
"zh-hans-cn\n"
"fr@collation=phonebook;calendar=islamic-civil\n"
"sr_Latn_RS_REVISED@currency=USD\n"
"en_IE@currency=IEP\n"
"en_IE_PREEURO\n"
"sr_Hans_Latn_RS_REVISED@currency=USD\n"
"fre_FR\n"
"und\n"
"fr@collation=phonebook;calendar=islamic-civil;currency=IEP")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")