use strict;
my $str = 'fr
fr-fr
fr_FR
zh_Hans_CN
zh-hans-cn
fr@collation=phonebook;calendar=islamic-civil
sr_Latn_RS_REVISED@currency=USD
en_IE@currency=IEP
en_IE_PREEURO
sr_Hans_Latn_RS_REVISED@currency=USD
fre_FR
und
fr@collation=phonebook;calendar=islamic-civil;currency=IEP';
my $regex = qr/^([a-zA-Z]{2,3})(([\-\_][a-zA-Z]{4})+)?([\-\_][a-zA-Z]{2})?([\-\_][a-zA-Z]*)?(@(collation|calendar|currency|numbers)\=[a-zA-Z]*[;]?((collation|calendar|currency|numbers)\=[a-zA-Z\-\_]*[;]?)*)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}