using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{8}(?="" batch from)";
string input = @"|09082022|LBYWNU|0|GSS TL-Aug-22|07/25/2022|PSPSPS|330021|318062|19|Reverses ""GS_TAE_ACC GBP MOR 31-AUG-22"" journal entry of ""GL_TAE_CCL_08102022071920.txt GS_TAE A 2022081017060 57204987"" batch from ""AUG-22"".|GS_TAE|20220908221130_CCL2GGL_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}