const regex = /\d{8}(?=" batch from)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{8}(?=" batch from)', 'gm')
const str = `|09082022|LBYWNU|0|GSS TL-Aug-22|07/25/2022|PSPSPS|330021|318062|19|Reverses "GS_TAE_ACC GBP MOR 31-AUG-22" journal entry of "GL_TAE_CCL_08102022071920.txt GS_TAE A 2022081017060 57204987" batch from "AUG-22".|GS_TAE|20220908221130_CCL2GGL_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}