re = /\d{8}(?=" batch from)/m
str = '|09082022|LBYWNU|0|GSS TL-Aug-22|07/25/2022|PSPSPS|330021|318062|19|Reverses "GS_TAE_ACC GBP MOR 31-AUG-22" journal entry of "GL_TAE_CCL_08102022071920.txt GS_TAE A 2022081017060 57204987" batch from "AUG-22".|GS_TAE|20220908221130_CCL2GGL_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end