use strict;
my $str = '|09082022|LBYWNU|0|GSS TL-Aug-22|07/25/2022|PSPSPS|330021|318062|19|Reverses "GS_TAE_ACC GBP MOR 31-AUG-22" journal entry of "GL_TAE_CCL_08102022071920.txt GS_TAE A 2022081017060 57204987" batch from "AUG-22".|GS_TAE|20220908221130_CCL2GGL_';
my $regex = qr/\d{8}(?=" batch from)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}