import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{8}(?=\" batch from)";
final String string = "|09082022|LBYWNU|0|GSS TL-Aug-22|07/25/2022|PSPSPS|330021|318062|19|Reverses \"GS_TAE_ACC GBP MOR 31-AUG-22\" journal entry of \"GL_TAE_CCL_08102022071920.txt GS_TAE A 2022081017060 57204987\" batch from \"AUG-22\".|GS_TAE|20220908221130_CCL2GGL_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}