using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\s]*[^;][\s]*server-id[\s]*=[\s]*(.\d)";
string input = @"# other settings you may need to change.
; server-id = 1
log_bin = /var/log/mysql/mysql-bin.log
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}