$re = '/[\s]*[^;][\s]*server-id[\s]*=[\s]*(.\d)/i';
$str = '# other settings you may need to change.
; server-id = 1
log_bin = /var/log/mysql/mysql-bin.log
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);