re = /[\s]*[^;][\s]*server-id[\s]*=[\s]*(.\d)/i
str = '# other settings you may need to change.
; server-id = 1
log_bin = /var/log/mysql/mysql-bin.log
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end