import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\s]*[^;][\\s]*server-id[\\s]*=[\\s]*(.\\d)";
final String string = "# other settings you may need to change.\n"
+ " ; server-id = 1\n"
+ "log_bin = /var/log/mysql/mysql-bin.log\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}