// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)[\s]*[^;][\s]*server-id[\s]*=[\s]*(.\d)").unwrap();
let string = "# other settings you may need to change.
; server-id = 1
log_bin = /var/log/mysql/mysql-bin.log
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}