#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*(?:image|btserve)).*mtonews\.com.*$"
Local $sString = "https://mtonews.com/rihanna-teams-up-with-lvmh-for-fashion-brand" & @CRLF & _
"https://mtonews.com/ciara-goes-naked-for-new-album-release" & @CRLF & _
"http://mtonews.com/rihanna-teams-up-with-lvmh-for-fashion-brand" & @CRLF & _
"http://mtonews.com/ciara-goes-naked-for-new-album-release" & @CRLF & _
"http://mtonews.com/ciara-goes-naked-for-new-album-release-2019" & @CRLF & _
"http://www.mtonews.com/ciara-goes-naked-for-new-album-release-2019" & @CRLF & _
"https://www.btserve.com/serve?t=bidt-sra&v=1&pubId=168&siteId=512&placementUid=5ae8e4105e-168%7C5&pgid=78ff2e45-8b3c-6a06-465f-2ac1a107f4f6&o=https://mtonews.com/&" & @CRLF & _
"https://mtonews.com/.image/t_share/MTYzOTYyODY2ODAwNTM1Mzc3/steve_marjorie.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")