use strict;
my $str = 'https://mtonews.com/rihanna-teams-up-with-lvmh-for-fashion-brand
https://mtonews.com/ciara-goes-naked-for-new-album-release
http://mtonews.com/rihanna-teams-up-with-lvmh-for-fashion-brand
http://mtonews.com/ciara-goes-naked-for-new-album-release
http://mtonews.com/ciara-goes-naked-for-new-album-release-2019
http://www.mtonews.com/ciara-goes-naked-for-new-album-release-2019
https://www.btserve.com/serve?t=bidt-sra&v=1&pubId=168&siteId=512&placementUid=5ae8e4105e-168%7C5&pgid=78ff2e45-8b3c-6a06-465f-2ac1a107f4f6&o=https://mtonews.com/&
https://mtonews.com/.image/t_share/MTYzOTYyODY2ODAwNTM1Mzc3/steve_marjorie.png';
my $regex = qr/^(?!.*(?:image|btserve)).*mtonews\.com.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}