import Foundation
let pattern = #"^(?!.*(?:image|btserve)).*mtonews\.com.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://mtonews.com/rihanna-teams-up-with-lvmh-for-fashion-brand
https://mtonews.com/ciara-goes-naked-for-new-album-release
http://mtonews.com/rihanna-teams-up-with-lvmh-for-fashion-brand
http://mtonews.com/ciara-goes-naked-for-new-album-release
http://mtonews.com/ciara-goes-naked-for-new-album-release-2019
http://www.mtonews.com/ciara-goes-naked-for-new-album-release-2019
https://www.btserve.com/serve?t=bidt-sra&v=1&pubId=168&siteId=512&placementUid=5ae8e4105e-168%7C5&pgid=78ff2e45-8b3c-6a06-465f-2ac1a107f4f6&o=https://mtonews.com/&
https://mtonews.com/.image/t_share/MTYzOTYyODY2ODAwNTM1Mzc3/steve_marjorie.png
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)