import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(?:image|btserve)).*mtonews\\.com.*$";
final String string = "https://mtonews.com/rihanna-teams-up-with-lvmh-for-fashion-brand\n"
+ "https://mtonews.com/ciara-goes-naked-for-new-album-release\n"
+ "http://mtonews.com/rihanna-teams-up-with-lvmh-for-fashion-brand\n"
+ "http://mtonews.com/ciara-goes-naked-for-new-album-release\n"
+ "http://mtonews.com/ciara-goes-naked-for-new-album-release-2019\n"
+ "http://www.mtonews.com/ciara-goes-naked-for-new-album-release-2019\n"
+ "https://www.btserve.com/serve?t=bidt-sra&v=1&pubId=168&siteId=512&placementUid=5ae8e4105e-168%7C5&pgid=78ff2e45-8b3c-6a06-465f-2ac1a107f4f6&o=https://mtonews.com/&\n"
+ "https://mtonews.com/.image/t_share/MTYzOTYyODY2ODAwNTM1Mzc3/steve_marjorie.png";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}