using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*(?:image|btserve)).*mtonews\.com.*$";
string input = @"https://mtonews.com/rihanna-teams-up-with-lvmh-for-fashion-brand
https://mtonews.com/ciara-goes-naked-for-new-album-release
http://mtonews.com/rihanna-teams-up-with-lvmh-for-fashion-brand
http://mtonews.com/ciara-goes-naked-for-new-album-release
http://mtonews.com/ciara-goes-naked-for-new-album-release-2019
http://www.mtonews.com/ciara-goes-naked-for-new-album-release-2019
https://www.btserve.com/serve?t=bidt-sra&v=1&pubId=168&siteId=512&placementUid=5ae8e4105e-168%7C5&pgid=78ff2e45-8b3c-6a06-465f-2ac1a107f4f6&o=https://mtonews.com/&
https://mtonews.com/.image/t_share/MTYzOTYyODY2ODAwNTM1Mzc3/steve_marjorie.png";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}