using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Z0-9_]+)";
string substitution = @"<div class=""form-group {\1_class}"">\r\t<div class=""col_label"">\r <label id=""ac_\1"" class=""form-label"">{\1_libelle}</label>\r </div>\r <div class=""col_champs"">\r {\1}\r </div>\r <div class=""aide"">\r <!--span class=""label label-info"">{\1_aide}</span-->\r </div>\r</div>\n\n";
string input = @"GENERATION_PDF
PDF_GENERE
PDF_GENERES";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}