use strict;
my $str = 'GENERATION_PDF
PDF_GENERE
PDF_GENERES';
my $regex = qr/^([A-Z0-9_]+)/mp;
my $subst = '<div class="form-group {\\1_class}">\\r\\t<div class="col_label">\\r <label id="ac_\\1" class="form-label">{\\1_libelle}</label>\\r </div>\\r <div class="col_champs">\\r {\\1}\\r </div>\\r <div class="aide">\\r <!--span class="label label-info">{\\1_aide}</span-->\\r </div>\\r</div>\\n\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";