// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Z0-9_]+)").unwrap();
let string = "GENERATION_PDF
PDF_GENERE
PDF_GENERES";
let substitution = "<div class=\"form-group {\\1_class}\">\\r\\t<div class=\"col_label\">\\r <label id=\"ac_\\1\" class=\"form-label\">{\\1_libelle}</label>\\r </div>\\r <div class=\"col_champs\">\\r {\\1}\\r </div>\\r <div class=\"aide\">\\r <!--span class=\"label label-info\">{\\1_aide}</span-->\\r </div>\\r</div>\\n\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}