import Foundation
let pattern = #"^([A-Z0-9_]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
GENERATION_PDF
PDF_GENERE
PDF_GENERES
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<div class="form-group {\1_class}">\r\t<div class="col_label">\r <label id="ac_\1" class="form-label">{\1_libelle}</label>\r </div>\r <div class="col_champs">\r {\1}\r </div>\r <div class="aide">\r <!--span class="label label-info">{\1_aide}</span-->\r </div>\r</div>\n\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)