#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^((http:\/\/|https:\/\/)?(www\.)?)"
Local $sString = "http://example.com" & @CRLF & _
"https://example.com" & @CRLF & _
"http://www.example.com" & @CRLF & _
"https://www.example.com" & @CRLF & _
"://www.example.com" & @CRLF & _
"www.example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")