$re = '/^((http:\/\/|https:\/\/)?(www\.)?)/mi';
$str = 'http://example.com
https://example.com
http://www.example.com
https://www.example.com
://www.example.com
www.example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);