using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((http:\/\/|https:\/\/)?(www\.)?)";
string input = @"http://example.com
https://example.com
http://www.example.com
https://www.example.com
://www.example.com
www.example.com";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}