#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\d*(?:[-_]+\d*)*$)[\w-]+$"
Local $sString = "abcd" & @CRLF & _
"as123" & @CRLF & _
"as_as" & @CRLF & _
"as_12" & @CRLF & _
"as-as" & @CRLF & _
"12as" & @CRLF & _
"12_1az" & @CRLF & _
"123_12" & @CRLF & _
"12-12----___" & @CRLF & _
"----" & @CRLF & _
"____" & @CRLF & _
"12-12_12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")