use strict;
my $str = 'abcd
as123
as_as
as_12
as-as
12as
12_1az
123_12
12-12----___
----
____
12-12_12';
my $regex = qr/^(?!\d*(?:[-_]+\d*)*$)[\w-]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}