using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\d*(?:[-_]+\d*)*$)[\w-]+$";
string input = @"abcd
as123
as_as
as_12
as-as
12as
12_1az
123_12
12-12----___
----
____
12-12_12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}