import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\d*(?:[-_]+\\d*)*$)[\\w-]+$";
final String string = "abcd\n"
+ "as123\n"
+ "as_as\n"
+ "as_12\n"
+ "as-as\n"
+ "12as\n"
+ "12_1az\n"
+ "123_12\n"
+ "12-12----___\n"
+ "----\n"
+ "____\n"
+ "12-12_12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}