$re = '/^(?!\d*(?:[-_]+\d*)*$)[\w-]+$/m';
$str = 'abcd
as123
as_as
as_12
as-as
12as
12_1az
123_12
12-12----___
----
____
12-12_12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);