const regex = /^([^(]+)\(([^)]+)\):\s([\w]+)\s([^:]*):\s(.*)\s\[([^\]]+)\]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^(]+)\\(([^)]+)\\):\\s([\\w]+)\\s([^:]*):\\s(.*)\\s\\[([^\\]]+)\\]$', 'gm')
const str = `C:\\Program Files x86\\Microsoft VisualStudio\\2021\\Community\\VC\\Tools\\MSVC\\14.28.29333\\include\\xmemory(702,82): warning C4244: 'initializing': conversion from 'double' to '_Objty', possible loss of data [G:\\agent\\_work\\48\\s\\Application\\FunctionLib.vcxproj]
C:\\Program Files (x86)\\Microsoft VisualStudio\\2021\\Community\\VC\\Tools\\MSVC\\14.28.29333\\include\\xmemory(702,82): warning C4244: 'initializing': conversion from 'double' to '_Objty', possible loss of data [G:\\agent\\_work\\48\\s\\Application\\FunctionLib.vcxproj]
P:\\Application\\PativeCommon\\Cws2essel.h(50): warning C26812: The enum type 'Cws2essel::eVesselSource' is unscoped. Prefer 'enum class' over 'enum' (Enum.3). [P:\\PativeFunctionLib.vcxproj]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}