# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^(]+)\(([^)]+)\):\s([\w]+)\s([^:]*):\s(.*)\s\[([^\]]+)\]$"
test_str = ("C:\\Program Files x86\\Microsoft VisualStudio\\2021\\Community\\VC\\Tools\\MSVC\\14.28.29333\\include\\xmemory(702,82): warning C4244: 'initializing': conversion from 'double' to '_Objty', possible loss of data [G:\\agent\\_work\\48\\s\\Application\\FunctionLib.vcxproj]\n"
"C:\\Program Files (x86)\\Microsoft VisualStudio\\2021\\Community\\VC\\Tools\\MSVC\\14.28.29333\\include\\xmemory(702,82): warning C4244: 'initializing': conversion from 'double' to '_Objty', possible loss of data [G:\\agent\\_work\\48\\s\\Application\\FunctionLib.vcxproj]\n"
"P:\\Application\\PativeCommon\\Cws2essel.h(50): warning C26812: The enum type 'Cws2essel::eVesselSource' is unscoped. Prefer 'enum class' over 'enum' (Enum.3). [P:\\PativeFunctionLib.vcxproj]\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.