// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^(]+)\(([^)]+)\):\s([\w]+)\s([^:]*):\s(.*)\s\[([^\]]+)\]$").unwrap();
let string = "C:\\Program Files x86\\Microsoft VisualStudio\\2021\\Community\\VC\\Tools\\MSVC\\14.28.29333\\include\\xmemory(702,82): warning C4244: 'initializing': conversion from 'double' to '_Objty', possible loss of data [G:\\agent\\_work\\48\\s\\Application\\FunctionLib.vcxproj]
C:\\Program Files (x86)\\Microsoft VisualStudio\\2021\\Community\\VC\\Tools\\MSVC\\14.28.29333\\include\\xmemory(702,82): warning C4244: 'initializing': conversion from 'double' to '_Objty', possible loss of data [G:\\agent\\_work\\48\\s\\Application\\FunctionLib.vcxproj]
P:\\Application\\PativeCommon\\Cws2essel.h(50): warning C26812: The enum type 'Cws2essel::eVesselSource' is unscoped. Prefer 'enum class' over 'enum' (Enum.3). [P:\\PativeFunctionLib.vcxproj]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}