$re = '/^([^(]+)\(([^)]+)\):\s([\w]+)\s([^:]*):\s(.*)\s\[([^\]]+)\]$/m';
$str = 'C:\\Program Files x86\\Microsoft VisualStudio\\2021\\Community\\VC\\Tools\\MSVC\\14.28.29333\\include\\xmemory(702,82): warning C4244: \'initializing\': conversion from \'double\' to \'_Objty\', possible loss of data [G:\\agent\\_work\\48\\s\\Application\\FunctionLib.vcxproj]
C:\\Program Files (x86)\\Microsoft VisualStudio\\2021\\Community\\VC\\Tools\\MSVC\\14.28.29333\\include\\xmemory(702,82): warning C4244: \'initializing\': conversion from \'double\' to \'_Objty\', possible loss of data [G:\\agent\\_work\\48\\s\\Application\\FunctionLib.vcxproj]
P:\\Application\\PativeCommon\\Cws2essel.h(50): warning C26812: The enum type \'Cws2essel::eVesselSource\' is unscoped. Prefer \'enum class\' over \'enum\' (Enum.3). [P:\\PativeFunctionLib.vcxproj]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);