use strict;
my $str = 'C:\\Program Files x86\\Microsoft VisualStudio\\2021\\Community\\VC\\Tools\\MSVC\\14.28.29333\\include\\xmemory(702,82): warning C4244: \'initializing\': conversion from \'double\' to \'_Objty\', possible loss of data [G:\\agent\\_work\\48\\s\\Application\\FunctionLib.vcxproj]
C:\\Program Files (x86)\\Microsoft VisualStudio\\2021\\Community\\VC\\Tools\\MSVC\\14.28.29333\\include\\xmemory(702,82): warning C4244: \'initializing\': conversion from \'double\' to \'_Objty\', possible loss of data [G:\\agent\\_work\\48\\s\\Application\\FunctionLib.vcxproj]
P:\\Application\\PativeCommon\\Cws2essel.h(50): warning C26812: The enum type \'Cws2essel::eVesselSource\' is unscoped. Prefer \'enum class\' over \'enum\' (Enum.3). [P:\\PativeFunctionLib.vcxproj]
';
my $regex = qr/^([^(]+)\(([^)]+)\):\s([\w]+)\s([^:]*):\s(.*)\s\[([^\]]+)\]$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}