const regex = /url\(["|']*([^)\?]+\.\w{1,5})(\?[^)"']*)?["|']*\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('url\\(["|\']*([^)\\?]+\\.\\w{1,5})(\\?[^)"\']*)?["|\']*\\)', 'gm')
const str = ` src: url(.. / assets / fonts / INGMeWeb - Regular.eot?v=1.2);
src: url(".. / assets / fonts / INGMeWeb - Regular.eot?v=1.2");
src: url(.. / assets / fonts / ING.MeW.eb - Regular.eot?) format('embedded-opentype'), url("") format('woff'), url(.. / assets / fonts / INGMeWeb - Regular.ttf?v=2.3.23&w=23.34) format('truetype'), url(.. / assets / fonts / INGMeWeb - Regular.svg) format('svg');
font - style: normal
}
@font - face {
font - family: INGMeBold;
src: url(".. / assets / fonts / INGMeWeb - Bold.eot");
src: url('.. / assets / fonts / INGMeWeb - Bold.eot') format('embedded-opentype'), url(.. / assets / fonts / INGMeWeb - Bold.woff) format('woff'), url(.. / assets / fonts / INGMeWeb - Bold.ttf) format('truetype'), url(.. / assets / fonts / INGMeWeb - Bold.svg) format('svg');
font - style: normal`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}