import re
regex = re.compile(r"url\([\"|']*([^)\?]+\.\w{1,5})(\?[^)\"']*)?[\"|']*\)", flags=re.MULTILINE)
test_str = (" src: url(.. / assets / fonts / INGMeWeb - Regular.eot?v=1.2);\n"
"src: url(\".. / assets / fonts / INGMeWeb - Regular.eot?v=1.2\");\n"
" src: url(.. / assets / fonts / ING.MeW.eb - Regular.eot?) format('embedded-opentype'), url(\"\") format('woff'), url(.. / assets / fonts / INGMeWeb - Regular.ttf?v=2.3.23&w=23.34) format('truetype'), url(.. / assets / fonts / INGMeWeb - Regular.svg) format('svg');\n"
" font - style: normal\n"
"}\n"
"@font - face {\n"
" font - family: INGMeBold;\n"
" src: url(\".. / assets / fonts / INGMeWeb - Bold.eot\");\n"
" src: url('.. / assets / fonts / INGMeWeb - Bold.eot') format('embedded-opentype'), url(.. / assets / fonts / INGMeWeb - Bold.woff) format('woff'), url(.. / assets / fonts / INGMeWeb - Bold.ttf) format('truetype'), url(.. / assets / fonts / INGMeWeb - Bold.svg) format('svg');\n"
" font - style: normal")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")