re = /url\(["|']*([^)\?]+\.\w{1,5})(\?[^)"']*)?["|']*\)/m
str = ' src: url(.. / assets / fonts / INGMeWeb - Regular.eot?v=1.2);
src: url(".. / assets / fonts / INGMeWeb - Regular.eot?v=1.2");
src: url(.. / assets / fonts / ING.MeW.eb - Regular.eot?) format(\'embedded-opentype\'), url("") format(\'woff\'), url(.. / assets / fonts / INGMeWeb - Regular.ttf?v=2.3.23&w=23.34) format(\'truetype\'), url(.. / assets / fonts / INGMeWeb - Regular.svg) format(\'svg\');
font - style: normal
}
@font - face {
font - family: INGMeBold;
src: url(".. / assets / fonts / INGMeWeb - Bold.eot");
src: url(\'.. / assets / fonts / INGMeWeb - Bold.eot\') format(\'embedded-opentype\'), url(.. / assets / fonts / INGMeWeb - Bold.woff) format(\'woff\'), url(.. / assets / fonts / INGMeWeb - Bold.ttf) format(\'truetype\'), url(.. / assets / fonts / INGMeWeb - Bold.svg) format(\'svg\');
font - style: normal'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end