import Foundation
let pattern = #"url\(["|']*([^)\?]+\.\w{1,5})(\?[^)"']*)?["|']*\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
src: url(.. / assets / fonts / INGMeWeb - Regular.eot?v=1.2);
src: url(".. / assets / fonts / INGMeWeb - Regular.eot?v=1.2");
src: url(.. / assets / fonts / ING.MeW.eb - Regular.eot?) format('embedded-opentype'), url("") format('woff'), url(.. / assets / fonts / INGMeWeb - Regular.ttf?v=2.3.23&w=23.34) format('truetype'), url(.. / assets / fonts / INGMeWeb - Regular.svg) format('svg');
font - style: normal
}
@font - face {
font - family: INGMeBold;
src: url(".. / assets / fonts / INGMeWeb - Bold.eot");
src: url('.. / assets / fonts / INGMeWeb - Bold.eot') format('embedded-opentype'), url(.. / assets / fonts / INGMeWeb - Bold.woff) format('woff'), url(.. / assets / fonts / INGMeWeb - Bold.ttf) format('truetype'), url(.. / assets / fonts / INGMeWeb - Bold.svg) format('svg');
font - style: normal
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)