const regex = new RegExp('(H\\d+)\\s+([A-Za-z\\s]+)(?=\\s+\\d+\\.\\d)', 'g')
const str = `H1765 CONTI CANBERRA 13.4 278.8 CISC TSI 28/23:00 Sa 28/13:00 28/15 00/15 1595 1700`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}