use strict;
my $str = 'H1765 CONTI CANBERRA 13.4 278.8 CISC TSI 28/23:00 Sa 28/13:00 28/15 00/15 1595 1700';
my $regex = qr/(H\d+)\s+([A-Za-z\s]+)(?=\s+\d+\.\d)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}