import re
regex = re.compile(r"(H\d+)\s+([A-Za-z\s]+)(?=\s+\d+\.\d)")
test_str = "H1765 CONTI CANBERRA 13.4 278.8 CISC TSI 28/23:00 Sa 28/13:00 28/15 00/15 1595 1700"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")