#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([0-9]{7}[xX0-9]{1})\_([0-9]{3}|[0-9]{3}\-[0-9]{3})\_([0-9]{2}|[0-9]{2}\-[0-9]{2})\_.*\..*"
Local $sString = "23526963_013-014_01-03_s001_text.pdf"
Local $sSubst = "$1_$2_$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)