import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{7}[xX0-9]{1})\\_([0-9]{3}|[0-9]{3}\\-[0-9]{3})\\_([0-9]{2}|[0-9]{2}\\-[0-9]{2})\\_.*\\..*";
final String string = "23526963_013-014_01-03_s001_text.pdf";
final String subst = "$1_$2_$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}