use strict;
my $str = '23526963_013-014_01-03_s001_text.pdf';
my $regex = qr/([0-9]{7}[xX0-9]{1})\_([0-9]{3}|[0-9]{3}\-[0-9]{3})\_([0-9]{2}|[0-9]{2}\-[0-9]{2})\_.*\..*/p;
my $subst = '$1_$2_$3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";